re = /^(.+?),\s*(?:(.+?),)?\s*(.+?)$/m
str = 'city, state, country
city, country
Baltimore, MD, USA
Mosul, Afghanistan
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end