$re = '/\((?:[^()]*|\([^()]*\))*\)|(\w+)/m';
$str = 'if ((a and b) or (a and)) or (c and d) or (e and f)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);