$re = '/(unittime)(\D+)(\d+)(\D+)(,)/mi';
$str = '\\r\\n\\r\\n\\t\\"unittime\\":\\"2017010100 \\", \\r\\n\\t\\"count"\\r ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);