using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.* - Installing)\s([a-zA-Z\/-]*) [(](v[.0-9]*)";
string input = @" - Installing lubusin/laravel-decomposer (v1.2.2): Downloading (connecting...)Downloading (100%) ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}