package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{5}([-]|\s*)?(\d{4})?$`)
var str = `12345
12345-6789
12345 1234
123451234
12345 1234
12345 1234
1234512341
123451`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}