$re = '/^(?!.*\bnot good\b).*?(?= good\b)/m';
$str = 'text is good
text is not good
text is good good
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);