$re = '/\b(?:f\/\w+|\w+)\b|\S/m';
$str = 'This is a sentence containing: f/thiscanbeanything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);