#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*(youtu.*be.*)\/(watch\?v=|embed\/|v|shorts|)(.*?((?=[&#?])|$)).*"
Local $sString = "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index" & @CRLF & _
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o" & @CRLF & _
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s" & @CRLF & _
"http://www.youtube.com/embed/0zM3nApSvMg?rel=0" & @CRLF & _
"http://www.youtube.com/watch?v=0zM3nApSvMg" & @CRLF & _
"http://youtu.be/0zM3nApSvMg" & @CRLF & _
"https://youtu.be/zGft_R6wETY?feature=shared" & @CRLF & _
"https://youtube.com/shorts/0dPkkQeRwTI?feature=share" & @CRLF & _
"https://youtube.com/shorts/0dPkkQeRwTI"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")