#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w:\\[A-Za-z0-9_.\\\s\(\)\/]+\.\w+"
Local $sString = "C:\Windows\syswow64\MsiExec.exe -Embedding AA583DDB5809F74DF7508AA445B0C52E E Global\MSI0000" & @CRLF & _
"" & @CRLF & _
"C:\Windows\syswow64\safa\dasdsa\fgasfsaf\asgsaga\MsiExec.exe -Embedding AA583DDB5809F74DF7508AA445B0C52E E Global\MSI0000" & @CRLF & _
"" & @CRLF & _
""C:\Program Files (x86)\Windows Grep\grep32.exe" -p"C:\Program Files (x86)\Site24x7\WebApp RBM Recorder"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"C:\Program Files (x86)\Site24x7\WebApp RBM Recorder"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")