import Foundation
let pattern = #"^.*\d/\h*\d.*(?:\R(?!END OF REPORT).*)*\REND OF REPORT\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
TRAFFIC MEASUREMENT REPORT PART 1/ 6 VLR MEASUREMENT VLRMEAS
SAMPLE DATE: FROM 2020-10-22 14:00:00:09
TO 2020-10-22 15:00:00:13
REGISTERED SUBSCRIBERS:
LOCATION AREA CODE CURRENT AVERAGE TMS1 TMS2 TMS3
UNKNOWN LAC 2 2 0 0 0
113 75868 75749 0 0 0
115 40627 40732 0 0 0
1102 70422 70489 0 0 0
1105 87075 87067 0 0 0
1117 56150 56180 0 0 0
1118 67175 67444 0 0 0
1120 74385 74381 0 0 0
1121 65034 65060 0 0 0
1122 21636 21407 0 0 0
1217 22944 22856 0 0 0
1218 49054 48993 0 0 0
1318 24283 24066 0 0 0
1418 16366 16350 0 0 0
2118 17812 17674 0 0 0
2120 79644 79489 0 0 0
TOTAL 768477 767939 0 0 0
PART 1/ 6
END OF REPORT
testing some data
here
TRAFFIC MEASUREMENT REPORT PART 2/ 6 VLR MEASUREMENT VLRMEAS
SAMPLE DATE: FROM 2020-10-22 14:00:00:09
TO 2020-10-22 15:00:00:13
REGISTERED SUBSCRIBERS:
LOCATION AREA CODE CURRENT AVERAGE TMS1 TMS2 TMS3
UNKNOWN LAC 2 2 0 0 0
113 75868 75749 0 0 0
115 40627 40732 0 0 0
1102 70422 70489 0 0 0
1105 87075 87067 0 0 0
1117 56150 56180 0 0 0
1118 67175 67444 0 0 0
1120 74385 74381 0 0 0
1121 65034 65060 0 0 0
1122 21636 21407 0 0 0
1217 22944 22856 0 0 0
1218 49054 48993 0 0 0
1318 24283 24066 0 0 0
1418 16366 16350 0 0 0
2118 17812 17674 0 0 0
2120 79644 79489 0 0 0
TOTAL 768477 767939 0 0 0
PART 2/ 6
END OF REPORT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)