$re = '/^(([A-Z0-9?&%^](?![a-z]))+|([a-z0-9?&%^](?![A-Z]))+)$/m';
$str = 'asd
ASED
asd2323
ABC123&^
Asds
Asd3434
AAsds
AB^%12c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);