package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)sadasd123`)
var str = `123123123123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}