package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^:]*:[^:]*){3,4}(?:, )`)
var str = `Checkers, etc:Blue::C, Backgammon, I say:Green::Pepsi:P, Chess, misc:White:Coke:Florida:A, :::U`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}