// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d: (.*)").unwrap();
let string = "Vou pegar tudo depois do número 1: esse é o trecho que quero pegar, até o final da linha
Esse trecho está em outra linha e não quero";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}