package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d: (.*?)\n`)
var str = `Vou pegar tudo depois do número 1: esse é o trecho que quero pegar, até o final da linha
Esse trecho está em outra linha e não quero`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}