$re = '/^(https?:\/\/)?(www\.)?([A-Za-zа-яА-Я\.]+).*/m';
$str = 'http://sto.mediaalyans.by/kontakty/
http://www.mediaalyans.by/hbg/5ckogu-sizai-100d50dsa150c406860hz
http://www.mediaalyans.by/blog/biznes-analitika/trends/
http://torcevik.mediaalyans.by/catalog/tapflo/ctv/
http://torcevik.mediaalyans.by/catalog/sihi/lem/
http://www.mediaalyans.by/portfolio-polygraf/
http://torcevik.mediaalyans.by/catalog/sigma/ecp/
http://www.mediaalyans.by/blog/socseti/
http://www.mediaalyans.by/yzd_19kobe-xmas063b180arcx
http://www.mediaalyans.by/blog/usability-ux/psychology-design/
http://www.mediaalyans.by/wch/50kg-maido89c0fy-17zh3a-w
http://www.медиаальянс.by/odq-58auc-fausto3408n01-10gd104cgl-1a
http://www.mediaalyans.by/qrw/e6worldcycle-wh970crud-k-0139sp397306z
http://www.mediaalyans.by/pjh/e2watch-shop65f2ci-at-0047
http://www.mediaalyans.by/gzko_b4rs-online9483cl-neo_plus-es6036-dr17v
http://www.mediaalyans.by/reklama-v-internete/bannernaya-reklama/
http://www.mediaalyans.by/tiee_56airu-shop2ce12sa-cleanbox-cl-l
https://www.mediaalyans.by/3-priema-tipografyky-na-saite/
mediaalyans.by/lgal/24merry-net4ac0bouonj-gp-sp
http://torcevik.mediaalyans.by/catalog/fristam/fl-fl3/
http://www.mediaalyans.by/5-trendov-goda-v-disaine/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);