re = /(?<!\S*)\s*See\sAlso\s*[:]?\s*(\s[A-Za-z0-9_\.]*)?\s*$/
str = 'See Also: something.m, something_else.m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end