$re = '/(?P<date>(0[1-9]|1[012])[-/.](0[1-9]|[12][0-9]|3[01])[-/.]((19|20)\d{2}))/m';
$str = 'this is due on 09-02-2021 at 10:00 am
this is due on 09/02/2021 at 10:00 am
this is due on 09.02.2021 at 10:00 am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);