$re = '/([a-zA-z ])\1{2,}$/i';
$str = 'rrr';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);