#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[0-9A-F]{32}$"
Local $sString = "fab4cc07260bc73302a2653aa2b0e6de" & @CRLF & _
"46cc38cc1039848dc287162cc4cf2532" & @CRLF & _
"a065c2cf24295a13725af9c5dc8cc76c" & @CRLF & _
"87d0f33c047915a0000ca972f3b32adc" & @CRLF & _
"43da9d5db71bedf3afc6f10fc8297a00" & @CRLF & _
"3fcca411d6774571a81a9faa4026c69a" & @CRLF & _
"9f36002354b2b75a069facac88ce5651" & @CRLF & _
"064ec24407084bf597c7dc1edc3f9017" & @CRLF & _
"3f5cfb400d72c7b3663b617368a0b3af"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")