$re = '~\/\*[\s\S]*?\*\/|([\'"])[\s\S]+?\1(*SKIP)(*FAIL)|\/{2}.*~x';
$str = '<?
/* This is a comment */
cout << "Hello
World"; // prints Hello World
/*
* C++ comments can also
*/
cout << "Hello World";
/* Comment out printing of Hello World:
cout << "Hello
World"; // prints Hello World
*/
echo "//This line was not a Comment, but ... ";
echo "http://stackoverflow.com";
echo \'http://stackoverflow.com/you can not match this line\';
array = [\'//\', \'no, you can not match this line!!\']
/* This is * //a comment */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);