import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\\.{2,}|[:,.](?!(?<=ό,)τι)(?!(?<=\\d.)\\d))(?!\\s*<br\\s*/>)\\s*";
final String string = "this ... ---\n"
+ "-----------------..............\n"
+ "Composition:80% Polyamide, 15% Elastane, 5% Wool.\n"
+ "Side length 50.5 cm <---- THIS SHOULDN'T BE MATCHED\n"
+ "Value 4,500 <---- THIS SHOULDN'T BE MATCHED EITHER\n\n"
+ "ό,τι <---- THIS IS A FIXED PHRASE IN GREEK AND THEREFORE SHOULDN'T BE MATCHED\n"
+ "Comfort and timeless design characterize the Puma Smash V2 made of suede leather. They can be worn all the time ,being a unique choice for those who want to stand out .Made of rubber.<br />- Softfoam floor<br />- Binding with laces\n\n"
+ "Specs:<br />• Something<br /><br />• Something else<br />• One more\n\n"
+ "Children's Form Champion<br /><br />Children's set that will give a comfortable feeling for endless hours of play.<br />It consists of a cardigan and trousers ,made of soft fabric and have rib cuffs and legs for a better fit.<br /><br />• Normal fit<br /><br />• Cardigan :Rib cuffs, zippers throughout length, high neck, Champion logo <br /> <br />• Pants: Elastic waist with drawstring, ribbed legs, Champion logo";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}