package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^.]{3})[^.]*\.[^.]+\.[^.]+$`)
var str = `aaa.bbbb.ccc4.ddd1.eee.fff
1112.2223.333.4445.555.6661.7773.8881.999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}