use strict;
my $str = 'This regexp can be used to validate domain names in Golang.
While it cannot enforce the 253 character limit (with optional trailing period not included)
that can be easily done with a `len(domain) <= 253` check.
This can be used as-is in other languages, even with RE2 regex engine.
Non-capturing groups are used.
Example validated domains (some may be invalid per TLD rules):
example.com
_25._tcp.SRV.example
a.punycoded-idna.xn--zckzah
under_score.example
0/27.0.0.1.in-addr.arpa
128/32.255.255.123.in-addr.arpa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.
Example invalid domains:
192.0.2.1
has spaces.com
easy,typo.example
23/1.invalid
domain\\.escapes.invalid
trailing_.underscore.invalid
-leading.hyphens.invalid
trailing-.hyphens.invalid
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
TLDs have more validation, the following will not validate:
a
example
digit.1example
underscore._example_com
but with a trailing period, the same rules as non-TLD are applied:
a.
example.
digit.1example.
underscore._example_com.
';
my $regex = qr`^(?:(?:[_a-z0-9](?:[_a-z0-9-]{0,61}[a-z0-9])?|[0-9]{1,3}?/[0-9]{2})\.)+(?:[a-z](?:[a-z0-9-]{0,61}[a-z0-9])?)?$`imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}