re = /<p>.*?(TEXT).*?<\/p>/
str = '<p>1 bla bla <em>bla</em> bla bla</p><p>2 bla bla <em>bla</em> bla TEXT bla</p><p>3 bla bla <em>bla</em> bla bla</p><p>4 bla bla <em>bla</em> bla TEXT bla</p><p>5 bla bla <em>bla</em> bla bla</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end