# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[Ss][Ll][Nn]\s+\d+\s+[Gg][Rr][Pp]\s+\d+\s+[S][T][Y][P]\s+['][T][Z][']\s+[Ss][Nn][Oo]\s+\d+\s+"
test_str = ("SLN 4 GRP 662 STYP 'TZ' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG 'PLA'\n"
"SLNB X1 -71629.6763 -89524.0401 34193.7197 X2 -70145.9264 -91487.9275 34193.7197\n"
"SLN 6 GRP 662 STYP 'TZ' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG 'PLA'\n"
"SLNB X1 -68645.9265 -89524.0401 34193.7197 X2 -67145.9265 -91487.9275 34193.7197\n"
"SLN 8 GRP 662 STYP 'TZ' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG 'PLA'\n"
"SLNB X1 -65780.9266 -89524.0401 34193.7197 X2 -64280.9267 -91487.9275 34193.7197\n"
"SLN 10 GRP 662 STYP 'TZ' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG 'PLA'\n"
"SLNB X1 -62780.9267 -89524.0401 34193.7197 X2 -61280.9268 -91487.9275 34193.7197\n"
"SLN 12 GRP 662 STYP 'TZ' SNO 1037 DRX 3.41018E-15 2.25685E-15 -1 XFLG 'PLA'\n"
"SLNB X1 -74597.1762 -89524.0401 34193.7197 X2 -76080.9261 -91487.9275 34193.7197\n"
"SLN 15 GRP 662 STYP 'TZ' SNO 1037 DRX -0.218907 0.519243 -0.826115 XFLG 'PLA'\n"
"SLNB X1 -71629.6763 -95007.3548 31588.4632 X2 -73113.4262 -91487.9275 34193.7197\n"
"SLN 16 GRP 662 STYP 'TZ' SNO 1037 DRX 0.218907 0.519243 -0.826115 XFLG 'PLA'\n"
"SLNB X1 -70145.9264 -91487.9275 34193.7197 X2 -71629.6763 -95007.3548 31588.4632\n"
"SLN 17 GRP 662 STYP 'TZ' SNO 1037 DRX -0.215802 0.515972 -0.828976 XFLG 'PLA'\n"
"SLNB X1 -68645.9265 -95074.3499 31570.9694 X2 -70145.9264 -91487.9275 34193.7197\n"
"SLN 18 GRP 662 STYP 'TZ' SNO 1037 DRX 0.215802 0.515972 -0.828976 XFLG 'PLA'\n"
"SL")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.