$re = '/(?<=Pay[\s]\$)([\d]+\.[\d]+)/m';
$str = 'Pay $3.14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);