// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<CompleteMatch>(?:(?<DateMonthYear>\d{4}-\d{2}-\d{2})T(?<Time>\d{2}:\d{2}:\d{2}(?:\.\d+)?))(?<TimeZone>Z|[\+-]\d{2}:\d{2})?)$").unwrap();
let string = "2023-01-28T13:25:00.00-05:00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}