re = /((\d{3}|\(\d{3}\))?(\s|-|\.)?\d{3}(\s|-|\.)\d{4}
(\s*(ext|x|ext.)\s*\d{2,5})?)/
str = '222-666-7777 ext 322'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end