package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[a-z][a-z0-9]*`)
var str = `1test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}