$re = '/#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})/m';
$str = '#aaaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);