re = /^Z(?:I[^U]|[^I][U]|[^I][^U]).*$/m
str = 'ZISADR
ZIUSADR
ZDDDDR
ZISADR
ZBUASD
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end