$re = '/(?:\([^()]*\)|[^,])+/m';
$str = 'test,Test,NEAR(this,that,DISTANCE=4),test again,"another test"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);