$re = '/(\()(.*?)(\)).*/m';
$str = 'test string (67r!) and (77)
//div[2]/a[1]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);