#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:https?://)(?:www\.)?imdb\.com/title/[a-z]+([0-9]+).*$"
Local $sString = "http://www.imdb.com/Title/tt2618986" & @CRLF & _
"http://www.google.com/tt2618986" & @CRLF & _
"https://www.imdb.com/Title/tt2618986" & @CRLF & _
"http://www.imdb.com/title/tt1979376/?ref_=nv_sr_1?ref_=nv_sr_1" & @CRLF & _
"http://imdb.com/Title/tt2618986" & @CRLF & _
"http://www.google.com/tt2618986" & @CRLF & _
"https://imdb.com/Title/tt2618986" & @CRLF & _
"http://www.imdb.com/title/tt1979376/?ref_=nv_sr_1?ref_=nv_sr_1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")