#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[A-Za-z]\d:)\w+(?=\D+ )"
Local $sString = "08:27:08,946 INFO [com.cars.bdlx.manageinvoice.common.ManageInvoiceService-170] (http-/0.0.0.0:8080-22) REQUEST:V4:dUowlr45NG88:GET_INVOICE_PDF InvoicePdfRequest[customerID=12345678,accountNumber=987654321,invoiceNumber=33333333,countryCode=UK,page=<null>,pageFrom=<null>,pageTo=<null>,copy=false,billingSystemID=MOB,date=<null>,brand=TIGER,callingSystem=Base,userId=777777777,additionalRights=<null>]" & @CRLF & _
"" & @CRLF & _
"08:27:08,244 INFO [TIME-460] (http-/0.0.0.0:8080-7) TIME:V4:YpXGo1j4dMcS:GET_INVOICE_PDF:0.048" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")