# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=REQUEST:V4:)\w+(?=\D+ )"
test_str = ("08:27:08,946 INFO [com.cars.bdlx.manageinvoice.common.ManageInvoiceService-170] (http-/0.0.0.0:8080-22) REQUEST:V4:dUowlr45NG88:GET_INVOICE_PDF InvoicePdfRequest[customerID=12345678,accountNumber=987654321,invoiceNumber=33333333,countryCode=UK,page=<null>,pageFrom=<null>,pageTo=<null>,copy=false,billingSystemID=MOB,date=<null>,brand=TIGER,callingSystem=Base,userId=777777777,additionalRights=<null>]\n\n"
"08:27:08,244 INFO [TIME-460] (http-/0.0.0.0:8080-7) TIME:V4:YpXGo1j4dMcS:GET_INVOICE_PDF:0.048\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.