// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([0-9a-f]{2})([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?([0-9a-f]{2})?").unwrap();
let string = "some random text 000102030405060708090A0B0C0D0E0F101112131415161718191A1B1C1D1E1F202122
and more text";
let substitution = "\\t0x$1${2:+,0x$2:}${3:+,0x$3:}${4:+,0x$4:}${5:+,0x$5:}${6:+,0x$6:}${7:+,0x$7:}${8:+,0x$8:}${9:+,0x$9:}${10:+,0x$10:}${11:+,0x$11:}${12:+,0x$12:}${13:+,0x$13:}${14:+,0x$14:}${15:+,0x$15:}${16:+,0x$16:}\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}