package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(apple)`)
var str = `this applesauce is delicious
apple is delicious`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}