re = /^[\p{Z}\p{P}\p{L}]+$/m
str = 'GIORGI SHALAMBERIDZE
გიორგი შალამბერიძე
GIORGI SHALAMBERIDZE 4
გიორგი შალამბერიძე 4
John Doe
Charles III
Sr. Artur
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end