// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<filename>[^\/]+$)").unwrap();
let string = "/shared/logs/NONPR/btlp006249/wls/8.1/P/logs/applications/usageMeter-webservice-1.0.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}