// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\/?[a-z]*color(?:=[A-Z]+)?]").unwrap();
let string = "[valign px=-2][center][bgcolor=GREEN]TESTING[/bgcolor][/center][/valign]
color=GREEN] AND color] ---> Target ---> [bgcolor=GREEN] AND [/bgcolor]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}