$re = '/(\w)(\w+)/m';
$str = 'Pig latin is cool';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);