using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\d+)>\h*(\d+(?:\.\d+)?)\h*</\h*\1>";
string input = @"<5> 20825.24 </ 5> <7> 0.0 </ 7> <8> 0.0 </ 8>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}