$re = '/\b\w+\b(?=\s*(test|example))/';
$str = 'test test
example test
test example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);