$re = '/(\d+ - .*[\s\S]*?(?=\d+ -|\Z))/m';
$str = '3 - FGV
Question description
A - Alternative
B - Alternative
C - Alternative
D - Alternative
4 - FSV
Question description
A - Alternative
B - Alternative
C - Alternative
D - Alternative
...
150 - FTB
Question description
A - Alternative
B - Alternative
C - Alternative
D - Alternative';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);