re = /[A-Z][a-zA-Z]*(?=\s*(?:[A-Z][a-zA-Z]*\s+)*Inc\.)/
str = 'Parent company Test Alphabet Inc. announced'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end