package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+\?v=)(.+)`)
var str = ` https://www.youtube.com/watch?v=_Gtc-GtLlTk`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}