re = /\b(?:AL|AK|AZ|AR|CA|CO|CT|DE|DC|FL|GA|HI|ID|IL|IN|IA|KS|KY|LA|ME|MD|MA|MI|MN|MS|MO|MT|NE|NV|NH|NJ|NM|NY|NC|ND|OH|OK|OR|PA|RI|SC|SD|TN|TX|UT|VT|VA|WA|WV|WI|WY)(?:;|$)/m
str = 'United States WA;United States;Mexico;United States OR;United States PA
United States WA;United States PA
United States WA ;United States PA '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end