package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/[-a-z0-9]*\.linkedin\.com\/.*$`)
var str = `https://subdomain.linkedin.com/a/b/c/d/e
https://sub.dom.ain.linkedin.com/a/b/c/d/e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}